Quantcast

Video switching

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Video switching

mehroz
Hi guys,

I have Linphone SIP client and my UI allows me to switch call from audio to video and video to audio.

After call establishment, when i switch to video, it do so ! and when i switch back to audio , it works. But after that when i switch to video , it doesn't!

Any guess ? what could be wrong here?
Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Video switching

Nuno Reis
Hi!

Your problem is most likely related to the way freeswitch is negotiating SDP everytime you switch video/audio.

--

Nuno Miguel Reis | Unified Communication Systems
M. +351 913907481 | [hidden email]

WAVECOM-Soluções Rádio, S.A.
Cacia Park | Rua do Progresso, Lote 15

3800-639 AVEIRO | Portugal

T. +351 309 700 225 | F. +351 234 919 191

GPS | www.wavecom.pt

Description: Description: WavecomSignature

Publicity




On Wed, Jul 31, 2013 at 11:40 AM, mehroz <[hidden email]> wrote:
Hi guys,

I have Linphone SIP client and my UI allows me to switch call from audio to
video and video to audio.

After call establishment, when i switch to video, it do so ! and when i
switch back to audio , it works. But after that when i switch to video , it
doesn't!

Any guess ? what could be wrong here?
Thanks



--
View this message in context: http://freeswitch-users.2379917.n2.nabble.com/Video-switching-tp7593439.html
Sent from the freeswitch-users mailing list archive at Nabble.com.

_________________________________________________________________________
Professional FreeSWITCH Consulting Services:
[hidden email]
http://www.freeswitchsolutions.com

FreeSWITCH-powered IP PBX: The CudaTel Communication Server
http://www.cudatel.com

Official FreeSWITCH Sites
http://www.freeswitch.org
http://wiki.freeswitch.org
http://www.cluecon.com

FreeSWITCH-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org


_________________________________________________________________________
Professional FreeSWITCH Consulting Services:
[hidden email]
http://www.freeswitchsolutions.com

FreeSWITCH-powered IP PBX: The CudaTel Communication Server
http://www.cudatel.com

Official FreeSWITCH Sites
http://www.freeswitch.org
http://wiki.freeswitch.org
http://www.cluecon.com

FreeSWITCH-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Video switching

mehroz
yes exactly  Nuno Reis,
I am confused as how can I debug this issue? What and where something is wrong.
While looking at logs of freeswitch each time when switched, SDPs are same are I dont even see any error.
Please comment...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Video switching

mehroz
Upon further investigation, I have observed that FS is always changing the Video port while keeping the audio port same in SDP updates.
Probably this is the reason the video is lost after the 2nd switch from audio to video. and Eventually, the new offered video ports does not opens at system level (netstate -ntulp) and older ports can bee seen bound by Freeswitch, but a tcpdump on those new ports does show rtp data flowing.

Is that  the normal behaviour? if not, what could be the reason FS changing video ports in each new session. I am on Proxy mode.

Looking forward.
Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Video switching

Michael Jerris
Administrator
Please file a bug at jira.freeswitch.org

On Oct 22, 2013, at 9:56 AM, mehroz <[hidden email]> wrote:

> Upon further investigation, I have observed that FS is always changing the
> Video port while keeping the audio port same in SDP updates.
> Probably this is the reason the video is lost after the 2nd switch from
> audio to video. and Eventually, the new offered video ports does not opens
> at system level (netstate -ntulp) and older ports can bee seen bound by
> Freeswitch, but a tcpdump on those new ports does show rtp data flowing.
>
> Is that  the normal behaviour? if not, what could be the reason FS changing
> video ports in each new session. I am on Proxy mode.
>
> Looking forward.
> Thanks
>
>


_________________________________________________________________________
Professional FreeSWITCH Consulting Services:
[hidden email]
http://www.freeswitchsolutions.com

FreeSWITCH-powered IP PBX: The CudaTel Communication Server
http://www.cudatel.com

Official FreeSWITCH Sites
http://www.freeswitch.org
http://wiki.freeswitch.org
http://www.cluecon.com

FreeSWITCH-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Video switching

mehroz
Loading...