Root tag missing

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Root tag missing

sirimmfs
Hi,

I am looking at a system from a customer having an old version of Freeswitch. For some reason, freeswitch doesn't seem to start - logs are something like:

[ERR] switch_xml.c:1467 Short write!
[ERR] switch_xml.c:1467 Short write!
[ERR] switch_xml.c:1467 Short write!
[ERR] switch_xml.c:1467 Short write!
.
.
.
Cannot Initialize [[error near line 1]: root tag missing!

log/freeswitch.xml.fsxml is empty, and customer is not using xml_curl.

I ran xmllint, but couldn't really find any obvious problems. freeswitch.xml and vars.xml seem fine.. anything else that I could check? May be some xml is missing, but I am not sure which one!

_________________________________________________________________________
Professional FreeSWITCH Consulting Services:
[hidden email]
http://www.freeswitchsolutions.com

FreeSWITCH-powered IP PBX: The CudaTel Communication Server
http://www.cudatel.com

Official FreeSWITCH Sites
http://www.freeswitch.org
http://wiki.freeswitch.org
http://www.cluecon.com

FreeSWITCH-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Reply | Threaded
Open this post in threaded view
|

Re: Root tag missing

Michael Jerris
Administrator
Is the disk out of space or no permissions to create a file in the log directory?

On Oct 10, 2013, at 2:35 AM, Siri MM <[hidden email]> wrote:

> Hi,
>
> I am looking at a system from a customer having an old version of Freeswitch. For some reason, freeswitch doesn't seem to start - logs are something like:
>
> [ERR] switch_xml.c:1467 Short write!
> [ERR] switch_xml.c:1467 Short write!
> [ERR] switch_xml.c:1467 Short write!
> [ERR] switch_xml.c:1467 Short write!
> .
> .
> .
> Cannot Initialize [[error near line 1]: root tag missing!
>
> log/freeswitch.xml.fsxml is empty, and customer is not using xml_curl.
>
> I ran xmllint, but couldn't really find any obvious problems. freeswitch.xml and vars.xml seem fine.. anything else that I could check? May be some xml is missing, but I am not sure which one!


_________________________________________________________________________
Professional FreeSWITCH Consulting Services:
[hidden email]
http://www.freeswitchsolutions.com

FreeSWITCH-powered IP PBX: The CudaTel Communication Server
http://www.cudatel.com

Official FreeSWITCH Sites
http://www.freeswitch.org
http://wiki.freeswitch.org
http://www.cluecon.com

FreeSWITCH-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org