Re: New build gives error message for default grammar file??

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: New build gives error message for default grammar file??

Brian West
You're not in 1.0.3 you're in SVN trunk... The reason I know this is that wasn't changed till AFTER 1.0.3 was tagged and a new file set was used... please go into your libs dir and wipe out pocketsphinx and sphinx base.. then let it redownload them.  I'll make you a new tarball of the new grammar files which are in the jsgf format.  An example was added to scripts yes_no.gram ... word of warning the new pocketsphinx loads the entire dictionary on port open which on a machine of any speed should load the entire thing in 2 seconds or less... but here is the WARNING WARNING WARNING... If you happen to use words that aren't in the dictionary pocketsphinx WILL CRASH.. I am already on this with the dev's to work out a fix for this its been a long standing bug apparently in the lib.

/b

On Feb 24, 2009, at 1:36 PM, [hidden email] wrote:

I'm getting this error message trying out the pizza demo in FS 1.0.3:

 "Can't open dictionary C:\Program Files\FreeSWITCH\grammar\default.dic"

I didn't have this before where there was no default.dic file.

Is there some place a path has to be set now?

Thanks.



_______________________________________________
Freeswitch-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: New build gives error message for default grammar file??

Brian West
http://www.bkw.org/pizza_gram.tar.gz

/b

On Feb 24, 2009, at 1:36 PM, [hidden email] wrote:

I'm getting this error message trying out the pizza demo in FS 1.0.3:

 "Can't open dictionary C:\Program Files\FreeSWITCH\grammar\default.dic"

I didn't have this before where there was no default.dic file.

Is there some place a path has to be set now?

Thanks.



_______________________________________________
Freeswitch-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: New build gives error message for default grammar file??

mszlazak
In reply to this post by Brian West
Hi Brian,

It sounds like I'd be better off with 1.0.3 than SVN and will waiting for the fix?

But thanks for the files and info.

Mark.




-----Original Message-----
From: Brian West <[hidden email]>
To: [hidden email]
Sent: Tue, 24 Feb 2009 11:45 am
Subject: Re: [Freeswitch-users] New build gives error message for default grammar file??

You're not in 1.0.3 you're in SVN trunk... The reason I know this is that wasn't changed till AFTER 1.0.3 was tagged and a new file set was used... please go into your libs dir and wipe out pocketsphinx and sphinx base.. then let it redownload them.  I'll make you a new tarball of the new grammar files which are in the jsgf format.  An example was added to scripts yes_no.gram ... word of warning the new pocketsphinx loads the entire dictionary on port open which on a machine of any speed should load the entire thing in 2 seconds or less... but here is the WARNING WARNING WARNING... If you happen to use words that aren't in the dictionary pocketsphinx WILL CRASH.. I am already on this with the dev's to work out a fix for this its been a long standing bug apparently in the lib.

/b

On Feb 24, 2009, at 1:36 PM, [hidden email] wrote:

I'm getting this error message trying out the pizza demo in FS 1.0.3:

 "Can't open dictionary C:\Program Files\FreeSWITCH\grammar\default.dic"

I didn't have this before where there was no default.dic file.

Is there some place a path has to be set now?

Thanks.


=

_______________________________________________
Freeswitch-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: New build gives error message for default grammar file??

mszlazak
In reply to this post by Brian West
Hey Brian,

Where abouts do you keep the Window MSI 1.0.3 build that isn't in SVN trunk. Installing from the wiki installation page gets me a build with the same error.

Thanks. Mark.


-----Original Message-----
From: Brian West <[hidden email]>
To: [hidden email]
Sent: Tue, 24 Feb 2009 11:45 am
Subject: Re: [Freeswitch-users] New build gives error message for default grammar file??

You're not in 1.0.3 you're in SVN trunk... The reason I know this is that wasn't changed till AFTER 1.0.3 was tagged and a new file set was used... please go into your libs dir and wipe out pocketsphinx and sphinx base.. then let it redownload them.  I'll make you a new tarball of the new grammar files which are in the jsgf format.  An example was added to scripts yes_no.gram ... word of warning the new pocketsphinx loads the entire dictionary on port open which on a machine of any speed should load the entire thing in 2 seconds or less... but here is the WARNING WARNING WARNING... If you happen to use words that aren't in the dictionary pocketsphinx WILL CRASH.. I am already on this with the dev's to work out a fix for this its been a long standing bug apparently in the lib.

/b

On Feb 24, 2009, at 1:36 PM, [hidden email] wrote:

I'm getting this error message trying out the pizza demo in FS 1.0.3:

 "Can't open dictionary C:\Program Files\FreeSWITCH\grammar\default.dic"

I didn't have this before where there was no default.dic file.

Is there some place a path has to be set now?

Thanks.


=

_______________________________________________
Freeswitch-users mailing list
[hidden email]
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org
Loading...